InsightPhish US Beta - Service Degradation
Incident Report for Rapid7
Resolved
This incident has been resolved.
Posted Apr 12, 2018 - 21:59 UTC
Investigating
We are currently investigating an issue with InsightPhish that may prevent logging in or accessing the user interface.
Posted Apr 12, 2018 - 20:20 UTC