Issue with Report Downloads in EU/US3
Incident Report for Rapid7
Resolved
This incident has been resolved.

Download links for reports had expired resulting in invalid URLs to download the report. All new emails will have valid links, the old ones sent during the impact period will remain invalid. Share the report again from the app to generate an email with a valid link to download the reports.
Posted Jun 24, 2022 - 09:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2022 - 09:00 UTC
Investigating
We are currently investigating this issue.
Posted Jun 24, 2022 - 08:36 UTC
This incident affected: InsightIDR (EU) (API) and InsightIDR (US3) (API).