Rapid7 Customer Portal Degradation

Incident Report for Rapid7

Resolved

Access to the Rapid7 Customer Support Portal has been restored and we are no longer seeing signs of impact. We will continue to monitor and would encourage you to contact your Rapid7 Account Team if you experience any further difficulty accessing the portal.
Posted Sep 16, 2026 - 16:31 UTC

Update

We continue to see signs of recovery and are closely monitoring our vendor's progress and updates. For any urgent matters in the interim, please contact your Rapid7 Account Team directly by email or phone.
Posted Sep 16, 2026 - 14:32 UTC

Update

Our vendor has confirmed they are deploying a resolution to the issue affecting access to the Rapid7 Customer Support Portal. We are continuing to monitor progress and will provide a further update as the position changes. For any urgent matters in the interim, please contact your Rapid7 Account Team directly by email or phone.
Posted Sep 16, 2026 - 11:33 UTC

Update

We are continuing to monitor the vendor issue affecting access to the Rapid7 Customer Support Portal. For any urgent matters in the interim, please contact your Rapid7 Account Team directly by email or phone. We will share a further update as soon as the position changes.
Posted Sep 16, 2026 - 10:58 UTC

Monitoring

We are currently monitoring a vendor issue affecting access to the Rapid7 Customer Support Portal. Our teams are actively working to stabilise the service and restore customer access. In the interim, please contact your Rapid7 Account Team for assistance.
Posted Sep 16, 2026 - 09:27 UTC