Delays in Alerting Endpoint/Agent Data

Incident Report for Rapid7

Resolved

This incident has been resolved.
Posted Aug 23, 2025 - 20:05 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 23, 2025 - 20:01 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 23, 2025 - 19:53 UTC

Monitoring

Rapid7 has released a fix and is currently monitoring the active state
Posted Aug 23, 2025 - 19:26 UTC

Identified

Rapid7 has identified the underlying issue and are trying to identify a workaround right now.
Posted Aug 23, 2025 - 19:04 UTC

Investigating

We are currently experiencing delays in processing Endpoint/Agent data alerts. As a result, some alerts may be delayed in appearing within the platform .

Impact:
Customers may notice delayed visibility into certain endpoint/agent-based alerts.
No data has been lost; this is strictly a processing delay.

Current Status:
Rapid7 is actively investigating
Posted Aug 23, 2025 - 19:01 UTC
This incident affected: InsightIDR (US1) (Event Processing), InsightIDR (EU) (Event Processing), and InsightIDR (US3) (Event Processing).