Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jun 04, 2025 - 09:10 UTC
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jun 02, 2025 - 08:16 UTC
Update
Scheduled event processing Maintenance complete in US2, US3, US3, CA, EU, AU, AP for all effected applications. Maintenance continues in US1.
Posted Jun 02, 2025 - 08:15 UTC
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jun 02, 2025 - 08:09 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 30, 2025 - 08:00 UTC
Scheduled
The Rapid7 Data Platform will be undergoing maintenance at this time, during this time data ingestion may be delayed. User interfaces may be affected for the following experiences: Remediation Hub; IDR Alert Enrichment