Google Apps - Service Disruption

Incident Report for Rapid7

Resolved

The issue affecting data collection from Google Apps Event Sources has now been resolved.

Data collection should now be functioning as expected.
Posted May 18, 2025 - 03:26 UTC

Update

The issue affecting data collection from Google Apps Event Sources has now been resolved.

Data collection should now be functioning as expected. We will continue to monitor performance and provide further updates if necessary.

Thank you for your patience.
Posted May 18, 2025 - 02:15 UTC

Update

We are continuing to monitor for any further issues.
Posted May 18, 2025 - 02:14 UTC

Monitoring

The issue affecting data collection from Google Apps Event Sources has now been resolved.

Data collection should now be functioning as expected. We will continue to monitor performance and provide further updates if necessary.

Thank you for your patience.
Posted May 18, 2025 - 02:13 UTC

Investigating

Google Apps Event Source Disruption

We are currently experiencing a service disruption affecting data collection from Google Apps Event Sources. Our engineering team has identified the underlying issue and is actively working to restore full functionality as quickly as possible.

We are continuing to collaborate closely with our partners at Google to resolve the issue. Data collection will resume once the disruption has been fully addressed.

We will provide further updates as additional information becomes available.
Posted May 16, 2025 - 19:30 UTC
This incident affected: InsightIDR (US1) (Event Collection), InsightIDR (EU) (Event Collection), InsightIDR (CA) (Event Collection), InsightIDR (AU) (Event Collection), InsightIDR (AP) (Event Collection), InsightIDR (US2) (Event Collection), and InsightIDR (US3) (Event Collection).