Delays in Investigation Creation

Incident Report for Rapid7

Resolved

We have resolved the underlying issue. All investigations are now back in-sync and should be present within InsightIDR.
All other backlogs are now cleared and systems are operating as normal.
If you identify any continuing issues, please raise them via your normal support channels.
Thank you for your patience
Posted Jun 03, 2025 - 21:49 UTC

Update

We have identified the cause of the issue. Additional capacity has been allocated to work through the backlog of events.

Creating new investigations can be delayed by up to four hours. Some existing investigations will experience similar delays with new alert indicators being added to the timeline.
Posted Jun 03, 2025 - 17:36 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2025 - 15:57 UTC

Investigating

We are still investigating the issue across IDR investigation creation workflows.
Alerts creation is not affected, although some updates to associate alerts to investigations may be impacted.
Further updates will be provided in due course
Posted Jun 03, 2025 - 15:56 UTC
This incident affected: InsightIDR (EU) (Event Processing).