Increased volume of investigations

Incident Report for Rapid7

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 21:28 UTC

Monitoring

Between 6:00 PM and 12:30 AM UTC, customers in the US East and US West regions experienced a higher than normal volume of investigations. This issue has been resolved and systems are performing normally.

For our managed customers, the SOC is currently processing the remaining backlog of investigations
Posted Apr 09, 2026 - 08:55 UTC

Investigating

Some customers in US East and US West are experiencing a higher than normal volume of investigations.  The issue is no longer occurring, however we are looking into alerts received within the timeframe - 6pm to 12:30am UTC.

If you believe you have been affected by this issue, please log a support case with the subject line: increased-investigation-volume.
Posted Apr 09, 2026 - 05:12 UTC
This incident affected: SIEM (US3) (Data Processing) and SIEM (US2) (Data Processing).