Platform access for Threat Intelligence

Incident Report for Rapid7

Resolved

All systems have recovered and are confirmed as operating as normal.
Posted Jun 14, 2026 - 16:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2026 - 15:40 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2026 - 14:42 UTC

Investigating

We are currently investigating reports of platform access issues for Threat Intelligence.
Posted Jun 12, 2026 - 13:22 UTC
This incident affected: Threat Intelligence (EU) (User Interface), Threat Intelligence (US) (User Interface), Threat Intelligence (AP) (User Interface), Threat Intelligence (CA) (User Interface), and Threat Intelligence (AU) (User Interface).