InsightIDR - Data Collection, Processing and User Interface Degradation

Incident Report for Rapid7

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 18:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2025 - 14:54 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 04, 2025 - 14:34 UTC

Identified

The issue has been identified and a resolution is being implemented.
Posted Nov 04, 2025 - 14:22 UTC

Investigating

We are currently investigating an issue affecting InsightIDR. Users may experience degraded performance impacting data collection, processing, and elements of the user interface.
Posted Nov 04, 2025 - 13:52 UTC
This incident affected: InsightIDR (US1) (User Interface, Event Collection, Event Processing), InsightIDR (EU) (User Interface, Event Collection, Event Processing), Log Search (EU) (User Interface, Event Processing), and InsightIDR (AU) (User Interface, Event Collection, Event Processing).