Degradation in loading Exposure Analytics Dashboards in InsightVM

Incident Report for Rapid7

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 09:05 UTC

Update

Dashboard performance in the us-east-1 region has remained stable, with high availability and low latency. We are continuing to monitor to ensure stability persists.
Posted Aug 14, 2025 - 11:17 UTC

Update

Dashboard performance in the us-east-1 region is stable, with high availability and low latency. We will continue to monitor to ensure stability holds.
Posted Aug 14, 2025 - 01:17 UTC

Update

Dashboard performance in the US1 region is stable, with high availability and low latency. We will continue to monitor to ensure stability holds.
Posted Aug 13, 2025 - 15:10 UTC

Update

Dashboard performance have returned to normal, and our monitoring confirms that this issue is no longer occurring. We will continue to monitor the platform closely.
Posted Aug 12, 2025 - 22:02 UTC

Update

We have implemented a fix to address slow dashboard loading times, and we are now actively monitoring the system to ensure stability and performance. While the majority of users should see normal performance, some may still experience intermittent slowness.
Posted Aug 12, 2025 - 04:05 UTC

Monitoring

EA Dashboards and public API services are restored. Remediation Projects and Goals/SLAs processing has been temporarily paused to ensure data accuracy. Our teams are working to restore full functionality.
Posted Aug 12, 2025 - 01:31 UTC

Update

We are continuing to investigate the issue impacting the availability of EA Dashboards for some customers. Our team is making progress in isolating the root cause. We’ll share another update as soon as we have more details.
Posted Aug 11, 2025 - 23:33 UTC

Investigating

We have identified an issue where some customers may be experience problems loading EA Dashboards. The engineering team is actively investigating the issue.
Posted Aug 11, 2025 - 19:26 UTC
This incident affected: InsightVM (US1) (User Interface).