Degradation in Cloud Event Source data collection and iCON availability in US1

Incident Report for Rapid7

Resolved

This incident has been resolved.

Intermittent degradation in cloud connectivity within InsightConnect workflows in the US-EAST-1 and EU-CENTRAL regions was observed and remediated.

Workflows that rely on cloud connections may have failed. Additionally, workflows triggered by internal platform connections may not have started as expected e.g UBA or Detections Triggers.

Remediation Steps
Workflow Jobs can be rerun by navigating to failed jobs section in iCON.
Posted Jun 05, 2025 - 16:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2025 - 15:50 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 05, 2025 - 15:48 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 05, 2025 - 15:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 05, 2025 - 15:37 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 05, 2025 - 15:17 UTC

Update

We are continuing to investigate this issue.
Posted Jun 05, 2025 - 15:07 UTC

Investigating

We are currently investigating this issue.
Posted Jun 05, 2025 - 15:04 UTC
This incident affected: InsightConnect (US1) (User Interface), InsightIDR (US1) (Cloud Event Collection), and InsightIDR (EU) (Cloud Event Collection).