InsightIDR: Microsoft Office 365 Event Source Issue
Incident Report for Rapid7
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 12:50 UTC
Identified
A fix has been put in place. The team are continuing to monitor this. We see some event source instances have recovered automatically. Some customers may still need to manually re-create the event source, we are working on identifying those impacted accounts and will contact them directly.
Posted Jun 01, 2023 - 11:01 UTC
Investigating
We are currently investigating this issue where the Microsoft Office 365 event source is failing in all regions with a HTTP 401 response.
Posted Jun 01, 2023 - 09:33 UTC
This incident affected: InsightIDR (US1) (Event Collection), InsightIDR (EU) (Event Collection), InsightIDR (CA) (Event Collection), InsightIDR (AU) (Event Collection), InsightIDR (AP) (Event Collection), InsightIDR (US2) (Event Collection), and InsightIDR (US3) (Event Collection).