InsightVM Dashboards Failing to Load

Incident Report for Rapid7

Resolved

This incident has now been resolved.
Posted Mar 09, 2026 - 23:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2026 - 20:07 UTC

Identified

Rapid7 has identified the issue impacting Dashboards loading and is actively working on mitigation.
Posted Mar 09, 2026 - 19:46 UTC

Update

We are continuing to investigate this issue.
Posted Mar 09, 2026 - 19:27 UTC

Investigating

We are currently investigating an issue impacting InsightVM Dashboards across multiple regions.

Our teams are currently investigating this issue and will provide further updates as we make progress.
Posted Mar 09, 2026 - 18:26 UTC
This incident affected: Vulnerability Management (AP) (User Interface, Data Processing), Vulnerability Management (CA) (User Interface, Data Processing), Vulnerability Management (US2) (User Interface, Data Processing), and Vulnerability Management (US3) (User Interface, Data Processing).